はじめに

TxTran
固定長レコードのファイルを整形・加工する機能を持ったソフトウェアです。
現在でも基幹業務では、固定長レコードのファイルが頻繁に使用されています。
この固定長レコードというものは、データがベタ打ちとなっているため、データ個々の意味が分かり難かったり、欲しい部分だけを取り出すのが困難なものです。
本ソフトは、固定長レコードのファイルを整形・加工し、データを見やすくしたり、他のソフト(テキストエディタ、Excel等)で利用しやすくする機能を持っています。

機能、特徴

【レコード長変換機能】
  ・レコード長を指定バイトに変換できます。
  ・指定バイトを0にする事で、改行無しにも変換できます。

【固定長→CSV変換機能】
  レコード定義に従って、固定長からCSV(※1)へ変換できます。
  複数のレコード定義が混在、ネストしているデータも変換できます。(EOS,EDI等)
  レコード長の違う定義が混在しているデータも変換できます。
  PAC形式(※2)をテキスト形式に変換できます。
  CSVの区切り記号は、カンマの他、自由に設定する事ができます。
  必要なフィールドだけ出力する事ができます。
  作成したレコード定義をクリップボードにコピーし、Excel等に貼り付ける事ができます。

【改行コード変換機能】
  ・改行コードを CRLF, CR, LF に相互変換できます。

【その他】
  コマンドライン実行が可能です。バッチファイルに組み込む事ができます。

  ※1：CSV(Comma Separated Value)ファイルとは、各フィールドが","(カンマ)で区切られたテキストファイルの事です。様々なソフトで利用されています。
  ※2：PAC形式は、最終バイトの後ろ4bitが16進 1101('D') の時にマイナスと判定しています。

動作環境

  【対応OS】 Windows 95, 98, Me, 2000, XP
  【必要なもの】 VisualBasic 6.0 ランタイム


初期画面

TxTran.exe を実行すると、下記画面が表示されます。これがメインウィンドウです。

・レコード長変換　…　レコード長変換画面を表示します。
・REC->CSV変換　　…　固定長→CSV変換画面を表示します。
・改行コード変換　…　改行コード変換画面を表示します。

【ツールバーの説明】
  ・[ファイル]
      +[終了]　…　プログラムを終了します。
  ・[ツール]
      +[オプション設定]　…　オプション設定画面を表示します。
  ・[ヘルプ]
      +[TxTranヘルプ]　　…　TxTran のヘルプを表示します。
      +[バージョン情報]　…　バージョン情報画面を表示します。


レコード長変換

1) メインウィンドウでレコード長変換を選択すると、下記画面が表示されます。

・レコード長を変換する元ファイル名を、入力ファイル欄にフルパスで入力して下さい。
・レコード長変換後のファイル名を、出力ファイル欄にフルパスで入力して下さい。
※プルダウンから、以前入力したファイル名を選択する事ができます。（過去10件）
・入力が終わったら、[次へ]ボタンをクリックして下さい。

2) レコード長を指定する画面が表示されます。

・変換後のレコード長を入力して下さい。
※プルダウンから、よく使われる 64, 128, 256 を選択する事ができます。
・入力が終わったら、[次へ]ボタンをクリックして下さい。

3) 確認画面が表示されます。

・実行内容に問題が無ければ、[実行]ボタンをクリックして下さい。

4) 変換完了メッセージが表示されます。

・[OK]ボタンをクリックすると、メインウィンドウに戻ります。


固定長→CSV変換

1) メインウィンドウでREC->CSV変換を選択すると、下記画面が表示されます。

・固定長の元ファイル名を、入力ファイル欄にフルパスで入力して下さい。
・作成するCSVのファイル名を、出力ファイル欄にフルパスで入力して下さい。
※プルダウンから、以前入力したファイル名を選択する事ができます。（過去10件）
・入力が終わったら、[次へ]ボタンをクリックして下さい。

2) レコード定義を作成する画面が表示されます。

・[新規作成]ボタンをクリックして下さい。
※既にレコード定義を作成済みで、定義ファイルを保存してある場合は、[定義を開く]ボタンをクリックして、定義ファイルを指定して下さい。　>>6)へ

3) [新規作成]をクリックすると、ファイル定義の作成画面が表示されます。

・ファイル定義名　…　ファイルの定義名を入力して下さい。
・全てのレコード長を同一にする　…　固定長の場合はチェックを入れ、レコード長を指定して下さい。
・識別区分を使用する　…　レコード定義が複数あり、識別区分で判定する場合はチェックを入れ、識別区分が何桁目にあるかを指定して下さい。
・１行目にフィールド名を出力する　…　CSVファイルの1行目にフィールド名を出力する場合は、チェックを入れて下さい。
・フィールド区切り記号　…　フィールドを区切る文字を入力して下さい。（デフォルトはカンマ）

・上記入力が終わったら、[OK]ボタンをクリックして下さい。

4) 次に、レコード定義の作成画面が表示されます。

・レコード名　…　レコードの定義名を入力して下さい。
・レコード長　…　レコード長を入力して下さい。（ファイル定義で全てのレコード長を同一に設定した場合は不要）
・識別区分　　…　識別区分を入力して下さい。（複数桁 可）
・親レコード　…　複数のレコード定義がある時に、親レコードを指定して下さい。

・上記入力が終わったら、[OK]ボタンをクリックして下さい。
・2)の画面に戻ってくるので、右側のフィールド定義蘭で右クリックし、メニューから[フィールドの追加]を選択して下さい。

5) フィールド定義の作成画面が表示されます。

・フィールド名　…　フィールドの定義名を入力して下さい。
・タイプ　…　文字型：X、数値型：9、PAC型：P の何れかを選択して下さい。
・バイト数　…　フィールドの固定長でのバイト数を入力して下さい。
・小数点以下桁数　…　9タイプ及びPタイプの時に、小数点以下桁数を入力して下さい。
・メモ　…　メモ欄です。コメント等があれば、入力して下さい。

・上記入力が終わったら、[OK]ボタンをクリックして下さい。
※フィールドの数だけ、5)の作業を繰り返して下さい。
※追加フィールドは、追加指示時に選択していたフィールドの下に挿入されます。

6) これで１レコードの定義作成が完了しました。

・フィールドの追加・削除・変更は、キーボードの Ctrl+INS、Ctrl+DEL、Enter でも行えます。
・フィールドの移動は、右クリックメニューか、キーボードの Ctrl+↑、Ctrl+↓ で行えます。
・出力したくないフィールドは、フィールド名左のチェックを外して下さい。
・複数のレコード定義が必要な場合は、レコード定義蘭の上で右クリックし、メニューから[レコードの追加]を選択して下さい。
※レコード定義は、保存する事ができます。[定義を保存]ボタンをクリックし、定義ファイル名を指定して保存して下さい。
※レコード定義をクリップボードにコピーするには、右クリックメニューから[クリップボードにコピー]を選択して下さい。
・全ての入力が終わったら、[次へ]ボタンをクリックして下さい。

7) 確認画面が表示されます。

・実行内容に問題が無ければ、[実行]ボタンをクリックして下さい。

8) 変換完了メッセージが表示されます。

・[OK]ボタンをクリックすると、メインウィンドウに戻ります。


改行コード変換

1) メインウィンドウで改行コード変換を選択すると、下記画面が表示されます。

・改行コードを変換する元ファイル名を、入力ファイル欄にフルパスで入力して下さい。
・改行コード変換後のファイル名を、出力ファイル欄にフルパスで入力して下さい。
※プルダウンから、以前入力したファイル名を選択する事ができます。（過去10件）
・入力が終わったら、[次へ]ボタンをクリックして下さい。

2) 改行コードを指定する画面が表示されます。

・変換後の改行コードをプルダウンより選択して下さい。
・選択が終わったら、[次へ]ボタンをクリックして下さい。

3) 確認画面が表示されます。

・実行内容に問題が無ければ、[実行]ボタンをクリックして下さい。

4) 変換完了メッセージが表示されます。

・[OK]ボタンをクリックすると、メインウィンドウに戻ります。


オプション設定

メインウィンドウのツールバーから、[ツール]→[オプション設定]を選択すると、下記画面が表示されます。

・データファイルの既定フォルダ　…　入出力ファイルを指定する時に、最初に開くフォルダを指定する事ができます。
・レコード定義の既定フォルダ　…　固定長→CSV変換で、レコード定義を開く時、または保存する時に最初に開くフォルダを指定する事ができます。

・入力が終わったら、[OK]ボタンをクリックして下さい。


コマンドライン

TxTran [/パラメータ] [入力ファイル名] [出力ファイル名] [パラメータ内容]

<パラメータ>　L: レコード長変換　　C: 固定長→CSV変換　　E: 改行コード変換

例）
  TxTran /L input.dat output.txt 128 　　　　… ﾚｺｰﾄﾞ長を128ﾊﾞｲﾄに変換
  TxTran /C input.txt output.txt henkan.trd　… 定義ﾌｧｲﾙに従ってCSV変換
  TxTran /E input.txt output.txt LF　　　　　… 改行コードをLFに変換


著作権、免責

  本ソフトウェアはフリーウェアです。各自の責任において、ご自由にご利用下さい。
  ただし、著作権、他一切の権利は作者である神代が保有します。
  転載、配布は自由ですが、その場合にはアーカイブの内容を変更しないで下さい。
本ソフトウェアを使用する事によって生じたいかなる損害についても、作者は責任を負いかねますので、予めご了承下さい。


サポート、連絡先

サポート

  バグ報告やご意見・ご要望については、下記連絡先までご連絡下さい。
  ただし、作者の都合でご期待にそえない場合もございます。予めご了承下さい。

連絡先

  製作者： 神代 kumasiro@1kw.jp
  ホームページ： http://soft.sukima.client.jp